wiki:ShmInstallUbuntu

Version 16 (modified by MarcusWalther, 8 years ago) (diff)

--

Prerequisities for installation on Ubuntu systems

Please be sure that you have the following packages installed:

  • make
  • libmotif-dev
  • libc6-dev
  • tcsh
  • xterm
  • x11proto-core-dev
  • x11proto-print-dev
  • x11proto-xext-dev
  • libxt-dev
  • libx11-dev
  • xutils-dev
  • libxext-dev
  • libxt-dev

If you don't use the Adapt Manager, enter the command

sudo apt-get install make libmotif-dev libc6-dev tcsh xterm x11proto-core-dev x11proto-print-dev x11proto-xext-dev libxt-dev libx11-dev xutils-dev libxext-dev libxt-dev

and follow the instructions.

Incompatible motif libraries in Ubuntu

Important note: Motif libraries shipped with Ubuntu 9 and 10 are not compatible to SH/SHM. You can use the Ubuntu 8.04's libs as a quick and dirty fix (details see ticket #12).

> wget http://www.seismic-handler.org/portal/raw-attachment/ticket/12/libMrm.tar.bz2
> sudo tar xf libMrm.tar.bz2 -C /

Pre-compiled Ubuntu 8.04 package

If you prefer you can download a pre-compiled version of seismic handler that will install it to /usr/local/shcode/. This version was compiled with libah for reading AH files and also adapted to use a BASH shell startup script (shcode/setup/shsetup.sh) and the package can handle the addition of the correct lines to /etc/profile taking care of setup SH for all system users.

You must do:

  1. Download the package here  http://www.foo4fun.net/software/seismichandler_SH5.0e_SHM2.4i~0.1_i386.deb,
  2. Install it with gdebi: gdebi seismichandler_SH5.0e_SHM2.4i~0.1_i386.deb or double click this file from the file browser,
  3. Open a new gnome-terminal and configure it to load the shell as a login shell, to do that go to (menu path) Edit -> Current Profile -> Title and Command -> Run command as a login shell.
  4. Close your terminal, open it again and type in SHM.