wiki:Installation/openSUSE

Prerequisites for installation on openSUSE systems

Instructions apply to

  • openSUSE 12.2
  • openSUSE 12.1
  • openSUSE 11.4
  • openSUSE 11.3
  • openSUSE 11.2
  • openSUSE 11.1
  • openSUSE 11.0
  • openSUSE 10.3
  • openSUSE 10.2
  • SUSE Linux 10.1

Crossed out versions have reached  end of life, please visit the history of this page if instructions are not valid anymore.

Please be sure that you have the following packages installed (I had to hit "Retry" several times, because some packages weren't found at first):

  • gcc
  • openmotif-devel
  • make
  • rlwrap

The following packages should be installed already in desktop environments, but you should check for them!

  • tcsh
  • xterm
  • xorg-x11-libX11-devel
  • xorg-x11-libXt-devel

Using zypper the installation command is

zypper install gcc openmotif-devel make tcsh xterm xorg-x11-libX11-devel xorg-x11-libXt-devel rlwrap

Now proceed with download and installation of SH/SHM.

Known issues

  • On some installations using menu accelerator keys will crash the Motif version (reason is not known yet).
  • Some dialog boxes may show transparent frames around buttons, etc.
  • Some older versions of OpenSUSE ship with a defect UIL compiler. You can simply replace sh/source/motif/shm_world.uid by the file attached Download here.
  • Maybe standard motif file dialogs (e.g. "Read GSE" or "Recover EVT") lack button texts. The buttons work as intended. Functions are "Load", "Filter", "Cancel" (see attached picture Download).