wiki:Installation/Ubuntu

Version 15 (modified by MarcusWalther, 6 years ago) (diff)

--

Prerequisites for installation on Ubuntu systems

Instructions apply to

  • Ubuntu 12.04 (Precise)
  • Ubuntu 11.10 (Oneiric)
  • Ubuntu 11.04 (Natty)
  • Ubuntu 10.10 (Maverick)
  • Ubuntu 10.04 LTS (Lucid)
  • Ubuntu 9.10 (Karmic)
  • Ubuntu 9.04 (Jaunty)
  • Ubuntu 8.10 (Intrepid)
  • Ubuntu 8.04 LTS (Hardy)

and also variants like Kubuntu, Xubuntu, Lubuntu, ... Crossed out versions have reached  end of life, but these instructions might still be valid.

Please be sure that you have the following packages installed:

  • make
  • libmotif-dev
  • libc6-dev
  • tcsh
  • xterm
  • rlwrap
  • x11proto-core-dev
  • x11proto-print-dev
  • x11proto-xext-dev
  • libxt-dev
  • libx11-dev
  • xutils-dev
  • libxext-dev
  • libxpm-dev
  • xfonts-100dpi
  • xfonts-75dpi
  • xfs

If you don't use the Adapt Manager, enter the command

sudo apt-get install make libmotif-dev libc6-dev tcsh xterm rlwrap x11proto-core-dev x11proto-print-dev x11proto-xext-dev libxt-dev libx11-dev xutils-dev libxext-dev libxpm-dev xfonts-100dpi xfonts-75dpi xfs

and follow the instructions.

Now proceed with download and installation of SH/SHM.

Known issues

  • Ubuntu 10.x and 11.x: fprintf format warnings during compilation.
  • Ubuntu 9.x and 10.x: Motif libraries included are not compatible to SH/SHM. You can use the Ubuntu 8.04's libs as a quick and dirty fix (details see ticket #12).
    > wget http://www.seismic-handler.org/portal/raw-attachment/ticket/12/libMrm.tar.bz2
    > sudo tar xf libMrm.tar.bz2 -C /