Ticket #1 (closed defect: fixed)

Opened 10 years ago

Last modified 8 years ago

seclength larger than data length when read miniseed data

Reported by: Rainer Plokarz Owned by: MarcusWalther
Priority: low Milestone: Ongoing improvement of command line version
Component: SH Severity: blocker
Keywords: miniseed Cc:

Description

precondition:

  • miniseed files with different data length
  • all in same sfdfile
  • trying to read all data with fixed seclength (ShReads)

bug:

  • traces with data length less than scelength won't be read in
  • *** SEED-12 stream/time not found in SFD file ***

suggestion:

  • SH/SHM should read data as long it's available
  • automatically fill up missing samples

Change History

comment:1 Changed 10 years ago by MarcusWalther

  • Status changed from new to accepted

comment:2 Changed 10 years ago by MarcusWalther

  • Milestone set to Ongoing improvement of SH

comment:3 Changed 9 years ago by MarcusWalther

  • Type changed from enhancement to defect
  • Severity set to blocker

comment:4 Changed 9 years ago by MarcusWalther

Maybe r261 solves this issue.

comment:5 Changed 8 years ago by MarcusWalther

  • Status changed from accepted to closed
  • Resolution set to fixed

For several months no further information. Own tests show that the issue is resolved.

Note: See TracTickets for help on using tickets.